# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\|[^\S\n]*)\d+/\g<1>9/gm;t' <<< "banana | 10"