import Foundation
let pattern = #"(\|[^\S\n]*)\d+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"banana | 10"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\g<1>9"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)