package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\|[^\S\n]*)\d+`)
var str = `banana | 10`
var substitution = "\g<1>9"
fmt.Println(re.ReplaceAllString(str, substitution))
}