const regex = new RegExp('(\\|[^\\S\\n]*)\\d+', 'gm')
const str = `banana | 10`;
const subst = `\g<1>9`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);