import re
regex = re.compile(r"(\|[^\S\n]*)\d+", flags=re.MULTILINE)
test_str = "banana | 10"
subst = "\\g<1>9"
result = regex.sub(subst, test_str)
if result:
print(result)