# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(=[^-\r\n]+)-/\1_/gm;t' <<< "abcd-12=jksjd-jkkj-kjk
xyzm-87=hjahf-tyewg-766-gffg
zaqw-99=poiuy-12hd-0909-iuy"