import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(=[^-\\r\\n]+)-";
final String string = "abcd-12=jksjd-jkkj-kjk\n"
+ "xyzm-87=hjahf-tyewg-766-gffg\n"
+ "zaqw-99=poiuy-12hd-0909-iuy";
final String subst = "\\1_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}