#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(=[^-\r\n]+)-"
Local $sString = "abcd-12=jksjd-jkkj-kjk" & @CRLF & _
"xyzm-87=hjahf-tyewg-766-gffg" & @CRLF & _
"zaqw-99=poiuy-12hd-0909-iuy"
Local $sSubst = "\1_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)