$re = '/(=[^-\r\n]+)-/m';
$str = 'abcd-12=jksjd-jkkj-kjk
xyzm-87=hjahf-tyewg-766-gffg
zaqw-99=poiuy-12hd-0909-iuy';
$subst = "\1_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;