using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(=[^-\r\n]+)-";
string substitution = @"\1_";
string input = @"abcd-12=jksjd-jkkj-kjk
xyzm-87=hjahf-tyewg-766-gffg
zaqw-99=poiuy-12hd-0909-iuy";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}