import Foundation
let pattern = #"(=[^-\r\n]+)-"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abcd-12=jksjd-jkkj-kjk
xyzm-87=hjahf-tyewg-766-gffg
zaqw-99=poiuy-12hd-0909-iuy
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)