package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(=[^-\r\n]+)-`)
var str = `abcd-12=jksjd-jkkj-kjk
xyzm-87=hjahf-tyewg-766-gffg
zaqw-99=poiuy-12hd-0909-iuy`
var substitution = "\1_"
fmt.Println(re.ReplaceAllString(str, substitution))
}