const regex = /^(.)(.*?)([^@]?)(?=@[^@]+$)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.)(.*?)([^@]?)(?=@[^@]+$)', 'mg')
const str = `a@example.com
ab@example.com
abc@example.com
abcd@example.com
abcde@example.com
abcdef@example.com
abcdefg@example.com
Ф@example.com
ФѰ@example.com
ФѰД@example.com
ФѰДӐӘӔӺ@example.com
"a@tricky@one"@example.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}