import re
regex = re.compile(r"^(.)(.*?)([^@]?)(?=@[^@]+$)", flags=re.MULTILINE)
test_str = ("a@example.com\n"
"ab@example.com\n"
"abc@example.com\n"
"abcd@example.com\n"
"abcde@example.com\n"
"abcdef@example.com\n"
"abcdefg@example.com\n"
"Ф@example.com\n"
"ФѰ@example.com\n"
"ФѰД@example.com\n"
"ФѰДӐӘӔӺ@example.com\n"
"\"a@tricky@one\"@example.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")