import Foundation
let pattern = #"^(.)(.*?)([^@]?)(?=@[^@]+$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a@example.com
ab@example.com
abc@example.com
abcd@example.com
abcde@example.com
abcdef@example.com
abcdefg@example.com
Ф@example.com
ФѰ@example.com
ФѰД@example.com
ФѰДӐӘӔӺ@example.com
"a@tricky@one"@example.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)