re = /^(.)(.*?)([^@]?)(?=@[^@]+$)/m
str = 'a@example.com
ab@example.com
abc@example.com
abcd@example.com
abcde@example.com
abcdef@example.com
abcdefg@example.com
Ф@example.com
ФѰ@example.com
ФѰД@example.com
ФѰДӐӘӔӺ@example.com
"a@tricky@one"@example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end