$re = '/^(.)(.*?)([^@]?)(?=@[^@]+$)/m';
$str = 'a@example.com
ab@example.com
abc@example.com
abcd@example.com
abcde@example.com
abcdef@example.com
abcdefg@example.com
Ф@example.com
ФѰ@example.com
ФѰД@example.com
ФѰДӐӘӔӺ@example.com
"a@tricky@one"@example.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);