#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+)\s-\W+(.+\b)\s*\W"
Local $sString = "1 - Donación y Merma *" & @CRLF & _
"2 - Devolución" & @CRLF & _
"3 - * Vencidos *" & @CRLF & _
"4 - Stock Seguridad" & @CRLF & _
"5 - * Revisar Saldos" & @CRLF & _
"6 - Unicaciones Cedi *"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")