import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)\\s-\\W+(.+\\b)\\s*\\W";
final String string = "1 - Donación y Merma *\n"
+ "2 - Devolución\n"
+ "3 - * Vencidos *\n"
+ "4 - Stock Seguridad\n"
+ "5 - * Revisar Saldos\n"
+ "6 - Unicaciones Cedi *";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}