using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)\s-\W+(.+\b)\s*\W";
string input = @"1 - Donación y Merma *
2 - Devolución
3 - * Vencidos *
4 - Stock Seguridad
5 - * Revisar Saldos
6 - Unicaciones Cedi *";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}