package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)\s-\W+(.+\b)\s*\W`)
var str = `1 - Donación y Merma *
2 - Devolución
3 - * Vencidos *
4 - Stock Seguridad
5 - * Revisar Saldos
6 - Unicaciones Cedi *`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}