re = /(\d+)\s-\W+(.+\b)\s*\W/m
str = '1 - Donación y Merma *
2 - Devolución
3 - * Vencidos *
4 - Stock Seguridad
5 - * Revisar Saldos
6 - Unicaciones Cedi *'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end