$re = '/(\d+)\s-\W+(.+\b)\s*\W/m';
$str = '1 - Donación y Merma *
2 - Devolución
3 - * Vencidos *
4 - Stock Seguridad
5 - * Revisar Saldos
6 - Unicaciones Cedi *';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);