const regex = /(\d+)\s-\W+(.+\b)\s*\W/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)\\s-\\W+(.+\\b)\\s*\\W', 'gm')
const str = `1 - Donación y Merma *
2 - Devolución
3 - * Vencidos *
4 - Stock Seguridad
5 - * Revisar Saldos
6 - Unicaciones Cedi *`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}