use strict;
my $str = '1 - Donación y Merma *
2 - Devolución
3 - * Vencidos *
4 - Stock Seguridad
5 - * Revisar Saldos
6 - Unicaciones Cedi *';
my $regex = qr/(\d+)\s-\W+(.+\b)\s*\W/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}