# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=1\n:).*/<10%/g;t' <<< "Name1
:100%
Name2
:234%
Name3
:
Name4
:63%
Name5
:12%"