const regex = /(?<=1\n:).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=1\\n:).*', 'g')
const str = `Name1
:100%
Name2
:234%
Name3
:
Name4
:63%
Name5
:12%`;
const subst = `<10%`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);