import Foundation
let pattern = #"(?<=1\n:).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Name1
:100%
Name2
:234%
Name3
:
Name4
:63%
Name5
:12%
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<10%"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)