use strict;
my $str = 'Name1
:100%
Name2
:234%
Name3
:
Name4
:63%
Name5
:12%';
my $regex = qr/(?<=1\n:).*/p;
my $subst = '<10%';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";