using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=1\n:).*";
string substitution = @"<10%";
string input = @"Name1
:100%
Name2
:234%
Name3
:
Name4
:63%
Name5
:12%";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}