re = /(?<=1\n:).*/
str = 'Name1
:100%
Name2
:234%
Name3
:
Name4
:63%
Name5
:12%'
subst = '<10%'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result