#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\/[a-zA-Z0-9_-]+){2,}$(?<!^(\/usr\/bin)|(\/usr\/lib)|(\/usr\/lib64)|(\/usr\/sbin)$)"
Local $sString = "/usr/bin" & @CRLF & _
"/usr/lib" & @CRLF & _
"/usr/lib64" & @CRLF & _
"/usr/sbin" & @CRLF & _
"" & @CRLF & _
"/bin/foldername" & @CRLF & _
"/boot/foldername" & @CRLF & _
"/etc/foldername" & @CRLF & _
"/home/foldername" & @CRLF & _
"/lib/foldername" & @CRLF & _
"/usr/lib64/foldername" & @CRLF & _
"/usr/sbin/foldername" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/opt/folder" & @CRLF & _
"/opt/folder/subfolder" & @CRLF & _
"/opt/folder" & @CRLF & _
"/var/folder" & @CRLF & _
"/tmp/notallow/" & @CRLF & _
"/tmp/also/notallow/" & @CRLF & _
"/opt/" & @CRLF & _
"/opt//not_valid" & @CRLF & _
"/opt/allow" & @CRLF & _
"/opt/all " & @CRLF & _
"/opt/all(" & @CRLF & _
"/opt/all/fol( er" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")