const regex = /^(\/[a-zA-Z0-9_-]+){2,}$(?<!^(\/usr\/bin)|(\/usr\/lib)|(\/usr\/lib64)|(\/usr\/sbin)$)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\\/[a-zA-Z0-9_-]+){2,}$(?<!^(\\\/usr\\\/bin)|(\\\/usr\\\/lib)|(\\\/usr\\\/lib64)|(\\\/usr\\\/sbin)$)', 'mg')
const str = `/usr/bin
/usr/lib
/usr/lib64
/usr/sbin
/bin/foldername
/boot/foldername
/etc/foldername
/home/foldername
/lib/foldername
/usr/lib64/foldername
/usr/sbin/foldername
/opt/folder
/opt/folder/subfolder
/opt/folder
/var/folder
/tmp/notallow/
/tmp/also/notallow/
/opt/
/opt//not_valid
/opt/allow
/opt/all
/opt/all(
/opt/all/fol( er
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}