import re
regex = re.compile(r"^(\/[a-zA-Z0-9_-]+){2,}$(?<!^(\/usr\/bin)|(\/usr\/lib)|(\/usr\/lib64)|(\/usr\/sbin)$)", flags=re.MULTILINE)
test_str = ("/usr/bin\n"
"/usr/lib\n"
"/usr/lib64\n"
"/usr/sbin\n\n"
"/bin/foldername\n"
"/boot/foldername\n"
"/etc/foldername\n"
"/home/foldername\n"
"/lib/foldername\n"
"/usr/lib64/foldername\n"
"/usr/sbin/foldername\n\n\n"
"/opt/folder\n"
"/opt/folder/subfolder\n"
"/opt/folder\n"
"/var/folder\n"
"/tmp/notallow/\n"
"/tmp/also/notallow/\n"
"/opt/\n"
"/opt//not_valid\n"
"/opt/allow\n"
"/opt/all \n"
"/opt/all(\n"
"/opt/all/fol( er\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")