$re = '/^(\/[a-zA-Z0-9_-]+){2,}$(?<!^(\/usr\/bin)|(\/usr\/lib)|(\/usr\/lib64)|(\/usr\/sbin)$)/m';
$str = '/usr/bin
/usr/lib
/usr/lib64
/usr/sbin
/bin/foldername
/boot/foldername
/etc/foldername
/home/foldername
/lib/foldername
/usr/lib64/foldername
/usr/sbin/foldername
/opt/folder
/opt/folder/subfolder
/opt/folder
/var/folder
/tmp/notallow/
/tmp/also/notallow/
/opt/
/opt//not_valid
/opt/allow
/opt/all
/opt/all(
/opt/all/fol( er
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);