import Foundation
let pattern = #"^(\/[a-zA-Z0-9_-]+){2,}$(?<!^(\/usr\/bin)|(\/usr\/lib)|(\/usr\/lib64)|(\/usr\/sbin)$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/usr/bin
/usr/lib
/usr/lib64
/usr/sbin
/bin/foldername
/boot/foldername
/etc/foldername
/home/foldername
/lib/foldername
/usr/lib64/foldername
/usr/sbin/foldername
/opt/folder
/opt/folder/subfolder
/opt/folder
/var/folder
/tmp/notallow/
/tmp/also/notallow/
/opt/
/opt//not_valid
/opt/allow
/opt/all
/opt/all(
/opt/all/fol( er
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)