using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\/[a-zA-Z0-9_-]+){2,}$(?<!^(\/usr\/bin)|(\/usr\/lib)|(\/usr\/lib64)|(\/usr\/sbin)$)";
string input = @"/usr/bin
/usr/lib
/usr/lib64
/usr/sbin
/bin/foldername
/boot/foldername
/etc/foldername
/home/foldername
/lib/foldername
/usr/lib64/foldername
/usr/sbin/foldername
/opt/folder
/opt/folder/subfolder
/opt/folder
/var/folder
/tmp/notallow/
/tmp/also/notallow/
/opt/
/opt//not_valid
/opt/allow
/opt/all
/opt/all(
/opt/all/fol( er
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}