import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\/[a-zA-Z0-9_-]+){2,}$(?<!^(\\/usr\\/bin)|(\\/usr\\/lib)|(\\/usr\\/lib64)|(\\/usr\\/sbin)$)";
final String string = "/usr/bin\n"
+ "/usr/lib\n"
+ "/usr/lib64\n"
+ "/usr/sbin\n\n"
+ "/bin/foldername\n"
+ "/boot/foldername\n"
+ "/etc/foldername\n"
+ "/home/foldername\n"
+ "/lib/foldername\n"
+ "/usr/lib64/foldername\n"
+ "/usr/sbin/foldername\n\n\n"
+ "/opt/folder\n"
+ "/opt/folder/subfolder\n"
+ "/opt/folder\n"
+ "/var/folder\n"
+ "/tmp/notallow/\n"
+ "/tmp/also/notallow/\n"
+ "/opt/\n"
+ "/opt//not_valid\n"
+ "/opt/allow\n"
+ "/opt/all \n"
+ "/opt/all(\n"
+ "/opt/all/fol( er\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}