use strict;
my $str = '/usr/bin
/usr/lib
/usr/lib64
/usr/sbin
/bin/foldername
/boot/foldername
/etc/foldername
/home/foldername
/lib/foldername
/usr/lib64/foldername
/usr/sbin/foldername
/opt/folder
/opt/folder/subfolder
/opt/folder
/var/folder
/tmp/notallow/
/tmp/also/notallow/
/opt/
/opt//not_valid
/opt/allow
/opt/all
/opt/all(
/opt/all/fol( er
';
my $regex = qr/^(\/[a-zA-Z0-9_-]+){2,}$(?<!^(\/usr\/bin)|(\/usr\/lib)|(\/usr\/lib64)|(\/usr\/sbin)$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}