#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "This is the Start for the Test : 1([\S\s]*?) This is the End for the Test : 1"
Local $sString = "1) /* This is the Start for the Test : 1 */" & @CRLF & _
"2) Lu8_Ret = GetStatus_1();" & @CRLF & _
"3) Lu8_Ret = Lu8_Ret + 1;" & @CRLF & _
"4)/* This is the End for the Test : 1 */" & @CRLF & _
"5)" & @CRLF & _
"6) /* This is the Start for the Test : 2 */" & @CRLF & _
"7) Lu8_Ret = GetStatus_2();" & @CRLF & _
"8) Lu8_Ret = Lu8_Ret + 1;" & @CRLF & _
"9) /* This is the End for the Test : 2 */" & @CRLF & _
"10) " & @CRLF & _
"11) /* This is the Start for the Test : 1 */" & @CRLF & _
"12) Lu8_Ret = GetStatus_1();" & @CRLF & _
"13) /* This is the End for the Test : 1 */"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")