// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"This is the Start for the Test : 1([\S\s]*?) This is the End for the Test : 1").unwrap();
let string = "1) /* This is the Start for the Test : 1 */
2) Lu8_Ret = GetStatus_1();
3) Lu8_Ret = Lu8_Ret + 1;
4)/* This is the End for the Test : 1 */
5)
6) /* This is the Start for the Test : 2 */
7) Lu8_Ret = GetStatus_2();
8) Lu8_Ret = Lu8_Ret + 1;
9) /* This is the End for the Test : 2 */
10)
11) /* This is the Start for the Test : 1 */
12) Lu8_Ret = GetStatus_1();
13) /* This is the End for the Test : 1 */";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}