package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`This is the Start for the Test : 1([\S\s]*?) This is the End for the Test : 1`)
var str = `1) /* This is the Start for the Test : 1 */
2) Lu8_Ret = GetStatus_1();
3) Lu8_Ret = Lu8_Ret + 1;
4)/* This is the End for the Test : 1 */
5)
6) /* This is the Start for the Test : 2 */
7) Lu8_Ret = GetStatus_2();
8) Lu8_Ret = Lu8_Ret + 1;
9) /* This is the End for the Test : 2 */
10)
11) /* This is the Start for the Test : 1 */
12) Lu8_Ret = GetStatus_1();
13) /* This is the End for the Test : 1 */`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}