import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "This is the Start for the Test : 1([\\S\\s]*?) This is the End for the Test : 1";
final String string = "1) /* This is the Start for the Test : 1 */\n"
+ "2) Lu8_Ret = GetStatus_1();\n"
+ "3) Lu8_Ret = Lu8_Ret + 1;\n"
+ "4)/* This is the End for the Test : 1 */\n"
+ "5)\n"
+ "6) /* This is the Start for the Test : 2 */\n"
+ "7) Lu8_Ret = GetStatus_2();\n"
+ "8) Lu8_Ret = Lu8_Ret + 1;\n"
+ "9) /* This is the End for the Test : 2 */\n"
+ "10) \n"
+ "11) /* This is the Start for the Test : 1 */\n"
+ "12) Lu8_Ret = GetStatus_1();\n"
+ "13) /* This is the End for the Test : 1 */";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}