re = /This is the Start for the Test : 1([\S\s]*?) This is the End for the Test : 1/
str = '1) /* This is the Start for the Test : 1 */
2) Lu8_Ret = GetStatus_1();
3) Lu8_Ret = Lu8_Ret + 1;
4)/* This is the End for the Test : 1 */
5)
6) /* This is the Start for the Test : 2 */
7) Lu8_Ret = GetStatus_2();
8) Lu8_Ret = Lu8_Ret + 1;
9) /* This is the End for the Test : 2 */
10)
11) /* This is the Start for the Test : 1 */
12) Lu8_Ret = GetStatus_1();
13) /* This is the End for the Test : 1 */'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end