using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"This is the Start for the Test : 1([\S\s]*?) This is the End for the Test : 1";
string input = @"1) /* This is the Start for the Test : 1 */
2) Lu8_Ret = GetStatus_1();
3) Lu8_Ret = Lu8_Ret + 1;
4)/* This is the End for the Test : 1 */
5)
6) /* This is the Start for the Test : 2 */
7) Lu8_Ret = GetStatus_2();
8) Lu8_Ret = Lu8_Ret + 1;
9) /* This is the End for the Test : 2 */
10)
11) /* This is the Start for the Test : 1 */
12) Lu8_Ret = GetStatus_1();
13) /* This is the End for the Test : 1 */";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}