import Foundation
let pattern = #"This is the Start for the Test : 1([\S\s]*?) This is the End for the Test : 1"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1) /* This is the Start for the Test : 1 */
2) Lu8_Ret = GetStatus_1();
3) Lu8_Ret = Lu8_Ret + 1;
4)/* This is the End for the Test : 1 */
5)
6) /* This is the Start for the Test : 2 */
7) Lu8_Ret = GetStatus_2();
8) Lu8_Ret = Lu8_Ret + 1;
9) /* This is the End for the Test : 2 */
10)
11) /* This is the Start for the Test : 1 */
12) Lu8_Ret = GetStatus_1();
13) /* This is the End for the Test : 1 */
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)