using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[HPGX]\d{3}(?:\+[HPGX]\d{3})*\b";
string input = @"random text H326 H243+H546+H677 H234+H333 some other random texts
X123 X234+X567 X567+X890+X654";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}