import re
regex = re.compile(r"\b[HPGX]\d{3}(?:\+[HPGX]\d{3})*\b", flags=re.MULTILINE)
test_str = ("random text H326 H243+H546+H677 H234+H333 some other random texts\n"
"X123 X234+X567 X567+X890+X654")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")