re = /\b[HPGX]\d{3}(?:\+[HPGX]\d{3})*\b/m
str = 'random text H326 H243+H546+H677 H234+H333 some other random texts
X123 X234+X567 X567+X890+X654'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end