// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[HPGX]\d{3}(?:\+[HPGX]\d{3})*\b").unwrap();
let string = "random text H326 H243+H546+H677 H234+H333 some other random texts
X123 X234+X567 X567+X890+X654";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}